Back to overview
Degraded

Partial Outage

Jan 24 at 10:37pm UTC
Affected services
Licensing & Distribution API
Webhooks
Dashboard
Distribution API (Legacy)

Resolved
Jan 25 at 02:39am UTC

Everything looks to be back to normal. Please reach out to support@keygen.sh if you encounter any issues, or if you have further questions about what occurred.

Created
Jan 24 at 10:37pm UTC

Today, we attempted to deploy an upgrade to our application that effected encrypted columns in our databases. Unfortunately, during the rollout, we discovered that lookups on certain encrypted attributes, such as license key, began to fail. We quickly found the cause of the problem, rolled back, and eventually deployed a fix.

During this time, you may have received 401 or 404 responses indicating that a license key did not exist, when it actually did.

We are continuing to monitor the situation and will be keeping this status update open for the next couple hours.

No data was lost during this incident; only lookups were effected.