Get in touch
Back
Resolved

Migrated to Comodo TLS Certificate

Started 30 Sep at 07:27pm HDT.

https://api.keygen.sh/v1/health
Created

Due to the widespread issues caused by Lets Encrypt and lack of support for outdated OpenSSL clients, we have moved to a Comodo TLS certificate. Moving forward, this should resolve all TLS connection issues caused by the expired Lets Encrypt root certificate, DST Root CA X3.

We unfortunately experienced around 10–15 minutes of downtime during the migration to the new CA due to a misconfiguration on our end, but everything should be green now.

Please reach out if you continue to experience any issues.

Posted 30 Sep at 07:27pm HDT.